util/gen_xmlpool: Don't write via shell redirection
[mesa.git] / src / util / xmlpool / meson.build
index ae7c951a097fa5206e5a66567ce9b004af1aaba4..1fce397e4723ef8e809a65c67b8b9e001c2e4523 100644 (file)
@@ -30,9 +30,9 @@ xmlpool_options_h = custom_target(
   input : ['gen_xmlpool.py', 't_options.h'],
   output : 'options.h',
   command : [
-    prog_python, '@INPUT@', meson.current_build_dir(), _langs,
+    prog_python, '@INPUT0@', '--template', '@INPUT1@', '--output', '@OUTPUT@',
+    '--localedir', meson.current_build_dir(), '--languages',  _langs,
   ],
-  capture : true,
   depend_files : _langs_po_files,
 )