meson: don't try to generate i18n translations on windows
[mesa.git] / src / util / xmlpool / meson.build
index 8d645ce385f2674f9c96b30137373dc111d5f75e..d0ecec4937fdd08e8e78e36ea081ee2a333c8a19 100644 (file)
@@ -30,11 +30,13 @@ xmlpool_options_h = custom_target(
   input : ['gen_xmlpool.py', 't_options.h'],
   output : 'options.h',
   command : [
-    prog_python, '@INPUT@', meson.current_source_dir(), _langs,
+    prog_python, '@INPUT0@', '--template', '@INPUT1@', '--output', '@OUTPUT@',
+    '--localedir', meson.current_build_dir(), '--languages',  _langs,
   ],
-  capture : true,
   depend_files : _langs_po_files,
 )
 
-i18n = import('i18n')
-i18n.gettext('xmlpool')
+if host_machine.system() != 'windows'
+  i18n = import('i18n')
+  i18n.gettext('xmlpool', install : false)
+endif