loader: add dri_driver option to override dri driver to load
[mesa.git] / src / util / xmlpool / t_options.h
index f0537e965b8a3cda894c51937691a0d5d9504dd4..d4881b334e1b69edd8998fcb239a75d2bca7fe82 100644 (file)
@@ -411,6 +411,11 @@ DRI_CONF_OPT_BEGIN(device_id, string, def) \
         DRI_CONF_DESC(en,gettext("Define the graphic device to use if possible")) \
 DRI_CONF_OPT_END
 
+#define DRI_CONF_DRI_DRIVER(def) \
+DRI_CONF_OPT_BEGIN(dri_driver, string, def) \
+        DRI_CONF_DESC(en,gettext("Override the DRI driver to load")) \
+DRI_CONF_OPT_END
+
 /**
  * \brief Gallium-Nine specific configuration options
  */