vulkan/wsi/x11: add sent image counter
[mesa.git] / src / vulkan / meson.build
index 7900938b3550040c8cbfb908b56c1eb9729e8b43..7a0661363aa35d04c9a9a269d4f84469eb0314ee 100644 (file)
@@ -32,7 +32,6 @@ if with_platform_x11
   vulkan_wsi_deps += [
     dep_xcb,
     dep_x11_xcb,
-    dep_xcb_dri2,
     dep_xcb_dri3,
     dep_xcb_present,
     dep_xcb_sync,
@@ -45,7 +44,7 @@ if with_platform_wayland
   vulkan_wsi_deps += dep_wayland_client
   vulkan_wsi_list += ['wayland']
 endif
-if with_platform_drm
+if system_has_kms_drm and not with_platform_android
   vulkan_wsi_args += '-DVK_USE_PLATFORM_DISPLAY_KHR'
   vulkan_wsi_deps += [dep_libdrm]
   vulkan_wsi_list += ['drm']
@@ -59,6 +58,9 @@ endif
 
 subdir('util')
 subdir('wsi')
-if get_option('vulkan-overlay-layer')
+if with_vulkan_overlay_layer
   subdir('overlay-layer')
 endif
+if get_option('vulkan-device-select-layer')
+  subdir('device-select-layer')
+endif