vulkan: drop unused include directories
[mesa.git] / src / vulkan / overlay-layer / meson.build
index 9d1bc97c13153de54d075b8af33f981e2b9815a3..08eaac4163a62b54f5d0e9e52b8ce56065004d56 100644 (file)
@@ -18,8 +18,6 @@
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-vklayer_install_dir = join_paths(get_option('prefix'), 'share', 'vulkan', 'explicit_layer.d')
-
 glslang = find_program('glslangValidator')
 
 overlay_shaders = [
@@ -35,29 +33,28 @@ endforeach
 
 vklayer_files = files(
   'overlay.cpp',
-  'vk_layer_table.cpp',
+  'overlay_params.c',
 )
 
 vklayer_mesa_overlay = shared_library(
   'VkLayer_MESA_overlay',
   vklayer_files, overlay_spv,
-  c_args : [c_vis_args, no_override_init_args],
-  cpp_args : [cpp_vis_args],
-  dependencies : [libimgui_core_dep, dep_dl],
-  include_directories : [inc_common, inc_vulkan_util],
+  c_args : [c_vis_args, no_override_init_args, vulkan_wsi_args],
+  cpp_args : [cpp_vis_args, vulkan_wsi_args],
+  dependencies : [idep_vulkan_util, idep_mesautil, vulkan_wsi_deps, libimgui_core_dep, dep_dl],
+  include_directories : [inc_include, inc_src],
   link_args : cc.get_supported_link_arguments(['-Wl,-Bsymbolic-functions', '-Wl,-z,relro']),
-  link_with : [libmesa_util, libvulkan_util],
-  install_dir : vklayer_install_dir,
   install : true
 )
 
-sdata = configuration_data()
-sdata.set('install_dir', vklayer_install_dir)
+install_data(
+  files('VkLayer_MESA_overlay.json'),
+  install_dir : join_paths(get_option('datadir'), 'vulkan', 'explicit_layer.d'),
+)
 
 configure_file(
-  input : 'VkLayer_MESA_overlay.json.in',
-  output : '@BASENAME@',
-  configuration : sdata,
-  install_dir : vklayer_install_dir,
-  install : true
+  input : files('mesa-overlay-control.py'),
+  output : '@PLAINNAME@',
+  configuration : configuration_data(), # only copy the file
+  install_dir: get_option('bindir'),
 )