vulkan-overlay/meson: use install_data instead of configure_file
[mesa.git] / src / vulkan / overlay-layer / meson.build
index 37fd7a3412adebfad0c3517a9c7f7ce3a5797a3e..19856f66d259ab3a4a44dac0281ed099ba088a5d 100644 (file)
@@ -53,9 +53,8 @@ install_data(
   install_dir : join_paths(get_option('datadir'), 'vulkan', 'explicit_layer.d'),
 )
 
-configure_file(
-  input : files('mesa-overlay-control.py'),
-  output : '@PLAINNAME@',
-  configuration : configuration_data(), # only copy the file
-  install_dir: get_option('bindir'),
+install_data(
+  'mesa-overlay-control.py',
+  install_dir : get_option('bindir'),
+  install_mode : 'r-xr-xr-x',
 )