util: Add a mapping from VkFormat to PIPE_FORMAT.
[mesa.git] / src / vulkan / util / meson.build
index 84a448624950581faa393fda26f05c82ffff1952..f4f7d1730e3941d20d031b97ae5a7cddd769b585 100644 (file)
@@ -22,6 +22,7 @@ files_vulkan_util = files(
   'vk_alloc.h',
   'vk_debug_report.c',
   'vk_debug_report.h',
+  'vk_format.c',
   'vk_util.c',
   'vk_util.h',
 )
@@ -51,8 +52,6 @@ idep_vulkan_util_headers = declare_dependency(
 )
 
 idep_vulkan_util = declare_dependency(
-  sources : vk_enum_to_str[1],
   link_with : libvulkan_util,
-  include_directories : include_directories('.'),
   dependencies : idep_vulkan_util_headers
 )