util: Add a mapping from VkFormat to PIPE_FORMAT.
[mesa.git] / src / vulkan / util / meson.build
index ca292bbf7d6c2edd7a50423f95c1b5a04bbceb97..f4f7d1730e3941d20d031b97ae5a7cddd769b585 100644 (file)
@@ -22,6 +22,7 @@ files_vulkan_util = files(
   'vk_alloc.h',
   'vk_debug_report.c',
   'vk_debug_report.h',
+  'vk_format.c',
   'vk_util.c',
   'vk_util.h',
 )
@@ -31,8 +32,8 @@ vk_enum_to_str = custom_target(
   input : ['gen_enum_to_str.py', vk_api_xml],
   output : ['vk_enum_to_str.c', 'vk_enum_to_str.h'],
   command : [
-    prog_python, '@INPUT0@', '--xml', '@INPUT1@', '--outdir',
-    meson.current_build_dir()
+    prog_python, '@INPUT0@', '--xml', '@INPUT1@',
+    '--outdir', meson.current_build_dir()
   ],
 )
 
@@ -44,3 +45,13 @@ libvulkan_util = static_library(
   c_args : [c_vis_args, vulkan_wsi_args],
   build_by_default : false,
 )
+
+idep_vulkan_util_headers = declare_dependency(
+  sources : vk_enum_to_str[1],
+  include_directories : include_directories('.')
+)
+
+idep_vulkan_util = declare_dependency(
+  link_with : libvulkan_util,
+  dependencies : idep_vulkan_util_headers
+)