util/hash_set: Rework the API to know about hashing
[mesa.git] / src / glsl / nir / nir_from_ssa.c
2015-01-15 Jason Ekstrandutil/hash_set: Rework the API to know about hashing
2015-01-15 Jason Ekstrandnir: Rename parallel_copy_copy to parallel_copy_entry...
2015-01-15 Jason Ekstrandnir/from_ssa: Clean up parallel copy handling and docum...
2015-01-15 Jason Ekstrandnir: Rename nir_block_following_if to nir_block_get_fol...
2015-01-15 Jason Ekstrandnir: Make load_const SSA-only
2015-01-15 Jason Ekstrandnir: Call nir_metadata_preserve more places
2015-01-15 Jason Ekstrandnir/metadata: Rename metadata_dirty to metadata_preserve
2015-01-15 Jason Ekstrandnir: Don't require a function in ssa_def_init
2015-01-15 Jason Ekstrandnir/from_ssa: Don't lower constant SSA values to registers
2015-01-15 Jason Ekstrandnir: Add a better out-of-SSA pass
2015-01-15 Jason Ekstrandnir: Add a function to detect if a block is immediately...
2015-01-15 Jason Ekstrandnir: Add a naieve from-SSA pass