Allow the formal engine to perform a same-cycle result in the ALU
[soc.git] / nix / soc.nix
1 { version }:
2
3 { lib, buildPythonPackage, yosys, runCommand, c4m-jtag, nmigen-soc
4 , libresoc-ieee754fpu, libresoc-openpower-isa, python }:
5
6 let
7 # If we use ../. as source, then any change to
8 # any unrelated Nix file would cause a rebuild,
9 # since the build would have access to it.
10 src = runCommand "libresoc-soc-source" {} ''
11 mkdir $out
12 cp -r ${../src} -T $out/src
13 cp -r ${../setup.py} -T $out/setup.py
14 cp -r ${../README.md} -T $out/README.md
15 cp -r ${../NEWS.txt} -T $out/NEWS.txt
16 '';
17 in
18 buildPythonPackage {
19 pname = "libresoc-soc";
20 inherit version src;
21
22 propagatedBuildInputs = [
23 c4m-jtag nmigen-soc python libresoc-ieee754fpu libresoc-openpower-isa yosys
24 ];
25
26 doCheck = false;
27
28 prePatch = ''
29 rm -r src/soc/litex
30 '';
31
32 pythonImportsCheck = [ "soc" ];
33
34 meta = with lib; {
35 homepage = "https://libre-soc.org/";
36 license = licenses.lgpl3Plus;
37 };
38 }