wip
[soc.git] / nix / ilang.nix
index c5f548f23743304a1278a9b0e7a4232b8b435c54..14099df4c634a8d2f2c0e4668b2af721ef4caeee 100644 (file)
@@ -11,11 +11,13 @@ stdenv.mkDerivation {
   strictDeps = true;
 
   nativeBuildInputs = (with python3Packages; [
-    python migen
+    python migen c4m-jtag nmigen-soc python libresoc-ieee754fpu libresoc-openpower-isa
   ]) ++ (with litexPkgs; [ litex litedram liteeth liteiclink litescope litesdcard ]);
 
   postPatch = ''
     patchShebangs --build .
+
+    export PYTHONPATH="${../src}:$PYTHONPATH"
   '';
 
   configurePhase = "true";