flake.nix: Clean up
[soc.git] / nix / pre-litex.nix
diff --git a/nix/pre-litex.nix b/nix/pre-litex.nix
deleted file mode 100644 (file)
index cf405e1..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-{ version }:
-
-{ runCommand, python3Packages, libresoc-pinmux }:
-
-let script = ''
-  mkdir pinmux
-  ln -s ${libresoc-pinmux} pinmux/ls180
-  export PINMUX="$(realpath ./pinmux)"
-  python3 -m soc.simple.issuer_verilog \
-    --debug=jtag --enable-core --enable-pll \
-    --enable-xics --enable-sram4x4kblock --disable-svp64 \
-    $out
-''; in
-runCommand "libresoc-ls1804k-pre-litex.v" {
-  inherit version;
-
-  nativeBuildInputs = (with python3Packages; [
-    libresoc-soc
-  ]) ++ [ libresoc-pinmux ];
-} script